Glide error 求解

利用glide下载项目的依赖


glide init
glide update

执行glide update时出现下列错误


[WARN]  Unable to checkout golang.org/x/net/context
[ERROR] Error looking for golang.org/x/net/context: Cannot detect VCS

似乎glide只能成功从github下载依赖,从golang.org或者gopkg.in都会下载失败,这是GFW的功劳吧,各位有什么好办法吗?大点的开源项目几十个依赖很常见,再加上依赖的依赖,总不能手工挨个下载吧。

已邀请:

songtianyi

赞同来自:

以我半年的go项目经验,只有golang.org/x 的需要单独下

cookedsteak

赞同来自:

需要更改/添加mirror.yaml 文件到用户目录下的.glide文件夹下,
然后...有啥加啥

要回复问题请先登录注册